<!DOCTYPE html>
<!--[if lt IE 7]><html
lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html
lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html
lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if (IE 9)&!(IEMobile)]><html
lang="en-US" class="no-js lt-ie10"><![endif]-->
<!--[if gt IE 9]><!--><html
lang="en-US" class="no-js"><!--<![endif]--><head><meta
name="uponit-website-verification" content="c1d651072369b0a0e0bc1d4ec381b0510e9078a234f0ef9165b6ac2c73e0f3c0"/> <script src="/cdn-cgi/apps/head/UcGU0nCb-iNgwcSAJhxZ3A71f-0.js"></script><script type="text/javascript" src="//static.apester.com/js/sdk/v2.0/apester-javascript-sdk.min.js" async></script> <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script> <script async='async' src="https://www.googletagservices.com/tag/js/gpt.js"></script> <script>var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];</script> <script>var gptAdSlots = [];
  googletag.cmd.push(function() {
  
  var lb_mapping = googletag.sizeMapping().
        addSize([1000, 480], [[970, 300], [970, 250], [970, 90], [728, 90]]).
        addSize([730, 480], [[728, 90]]).
        addSize([0, 0], [[320, 100]]).
        build();
        
  var mpu_mapping = googletag.sizeMapping().
        addSize([338, 200], [[336, 280], [300, 250], 'fluid']).
        addSize([0, 0], [[300, 250], 'fluid']).
        build();      

  var sky_mapping = googletag.sizeMapping().
        addSize([730, 480], [[300, 600], [160, 600], 'fluid']).
        addSize([0, 0], [[300, 250], 'fluid']).
        build();
    
 	gptAdSlots[0] = googletag.defineSlot('/264857099/BIN/ROS/LB_1', [[970, 300], [970, 250], [970, 90], [728, 90], [320, 100]], 'div-gpt-ad-LB_1').defineSizeMapping(lb_mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
 	gptAdSlots[1] = googletag.defineSlot('/264857099/BIN/ROS/MPU_1', [[336, 280], [300, 250], 'fluid'], 'div-gpt-ad-MPU_1').defineSizeMapping(mpu_mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
 	gptAdSlots[2] = googletag.defineSlot('/264857099/BIN/ROS/MPU_2', [[336, 280], [300, 250], 'fluid'], 'div-gpt-ad-MPU_2').defineSizeMapping(mpu_mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
 	gptAdSlots[3] = googletag.defineSlot('/264857099/BIN/ROS/MPU_3', [[336, 280], [300, 250], 'fluid'], 'div-gpt-ad-MPU_3').defineSizeMapping(mpu_mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
 	gptAdSlots[4] = googletag.defineSlot('/264857099/BIN/ROS/MPU_4', [[336, 280], [300, 250], 'fluid'], 'div-gpt-ad-in_article').addService(googletag.pubads());
 	gptAdSlots[5] = googletag.defineSlot('/264857099/BIN/ROS/MPU_5', [[336, 280], [300, 250], 'fluid'], 'div-gpt-ad-under_article').addService(googletag.pubads());
	gptAdSlots[6] = googletag.defineSlot('/264857099/BIN/ROS/MPU_6', [300, 250], 'div-gpt-ad-MPU_6').addService(googletag.pubads());
	gptAdSlots[7] = googletag.defineSlot('/264857099/BIN/ROS/SKY_1', [[300, 600], [160, 600], [300, 250], 'fluid'], 'div-gpt-ad-SKY_1').defineSizeMapping(sky_mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
 	gptAdSlots[8] = googletag.defineSlot('/264857099/BIN/ROS/SKY_2', [[300, 600], [160, 600], [300, 250], 'fluid'], 'div-gpt-ad-SKY_2').defineSizeMapping(sky_mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
 	gptAdSlots[9] = googletag.defineOutOfPageSlot('/264857099/BIN/ROS/FI_tag', 'div-gpt-ad-FI_tag').addService(googletag.pubads());
  	
  var pageType = 'other';
  var articleId = 0;
  if( $("body").hasClass("home") ){
  		pageType = 'homepage';
  }else if(  $("body").hasClass("single") ){
		articleId =  104972;
		
  		pageType = 'article';
  }
  
    googletag.pubads().setTargeting('BIN_pageType', pageType);
 	if(articleId){

 		googletag.pubads().setTargeting('BIN_articleID',String(articleId) );
	 }

    googletag.enableServices();
  });</script> <script>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</script> <meta
charset="UTF-8"><meta
name="google-site-verification" content="XkpMYghalP6PKFm4NsgroErzjSbpzO_L9oARiiGxnPU" /><meta
name="google-site-verification" content="DsHJxfBlE5pdUj5zCS9hagdrJHI8_l79H0vIUbE3uSA" /><meta
name="viewport" content="width=device-width, initial-scale=1"><meta
property="fb:pages" content="164071980437584" /><title>Record Setting Crowd at Passover Sacrifice Reenactment - Breaking Israel News | Latest News. Biblical Perspective.</title><link
rel="profile" href="//gmpg.org/xfn/11"><link
rel="pingback" href="https://www.breakingisraelnews.com/xmlrpc.php"><link
rel="shortcut icon" href="//www.breakingisraelnews.com/wp-content/uploads/2013/06/favicon.png"><link
rel="amphtml" href="https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/amp/"> <script type="text/javascript">var ajaxurl = 'https://www.breakingisraelnews.com/wp-admin/admin-ajax.php';</script> <link
rel="canonical" href="https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/" /><link
rel="publisher" href="https://plus.google.com/+Breakingisraelnews/videos"/><link
rel="dns-prefetch" href="//connect.facebook.net"><link
rel='dns-prefetch' href='//www.breakingisraelnews.com' /><link
rel='dns-prefetch' href='//connect.facebook.net' /><link
rel='dns-prefetch' href='//s.w.org' /><link
rel="alternate" type="application/rss+xml" title="Breaking Israel News | Latest News. Biblical Perspective. &raquo; Feed" href="https://www.breakingisraelnews.com/feed/" /><link
rel="alternate" type="application/rss+xml" title="Breaking Israel News | Latest News. Biblical Perspective. &raquo; Comments Feed" href="https://www.breakingisraelnews.com/comments/feed/" />
 <script type='text/javascript' data-cfasync='false'>_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.breakingisraelnews.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related"},"url_components":{"year":"2018","monthnum":"03","day":"27","post_id":"104972","postname":"record-setting-crowd-at-passover-sacrifice-reenactment","author":"adam_berkowitz"}};</script> <script type='text/javascript' data-cfasync='false'
        src='//apps.shareaholic.com/assets/pub/shareaholic.js'
        data-shr-siteid='beb3633007ad1889d562d8787e67c08d' async='async' ></script> <meta
name='shareaholic:site_name' content='Breaking Israel News | Latest News. Biblical Perspective.' /><meta
name='shareaholic:language' content='en-US' /><meta
name='shareaholic:url' content='https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/' /><meta
name='shareaholic:keywords' content='jerusalem, passover, redemption (geula), temple mount, waqf, biblical news, post' /><meta
name='shareaholic:article_published_time' content='2018-03-27T15:00:19+03:00' /><meta
name='shareaholic:article_modified_time' content='2018-03-27T16:06:52+03:00' /><meta
name='shareaholic:shareable_page' content='true' /><meta
name='shareaholic:article_author_name' content='Adam Eliyahu Berkowitz' /><meta
name='shareaholic:site_id' content='beb3633007ad1889d562d8787e67c08d' /><meta
name='shareaholic:wp_version' content='8.6.5' /><meta
name='shareaholic:image' content='https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Paschal-offering-2018.jpg' />
 <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.breakingisraelnews.com\/wp-includes\/js\/wp-emoji-release.min.js?v=3accdd"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link
rel='stylesheet' id='contact-form-7-css'  href='https://www.breakingisraelnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?v=3accdd' type='text/css' media='all' /><link
rel='stylesheet' id='wp-in-post-ads-css'  href='https://www.breakingisraelnews.com/wp-content/plugins/mts-wp-in-post-ads/public/css/wp-in-post-ads-public.css?v=3accdd' type='text/css' media='all' /><link
rel='stylesheet' id='abase-stylesheet-css'  href='https://www.breakingisraelnews.com/wp-content/themes/bin-v2/dist/css/style.css?v=3accdd' type='text/css' media='all' />
<!--[if lt IE 10]><link
rel='stylesheet' id='abase-ie-only-css'  href='https://www.breakingisraelnews.com/wp-content/themes/bin-v2/dist/css/ie.css?v=3accdd' type='text/css' media='all' />
<![endif]--> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-includes/js/jquery/jquery.js?v=3accdd'></script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-includes/js/jquery/jquery-migrate.min.js?v=3accdd'></script> <script type='text/javascript'>/*  */
var ubm_premium = {"impressions":{"add_url":"https:\/\/www.breakingisraelnews.com\/wp-content\/plugins\/ubm-premium\/ubm-premium-add-impression.php","for_rotating_banners":"enable"}};
/*  */</script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-content/plugins/ubm-premium/scripts.js?v=3accdd'></script> <script>// Declare the aBase namespace
		aBase = jQuery.extend({},{
			authenticated: 0,
			template_url: "https://www.breakingisraelnews.com/wp-content/themes/bin-v2", // A path to the theme template from root
			home_url: "https://www.breakingisraelnews.com",
			ajax_url: "https://www.breakingisraelnews.com/wp-admin/admin-ajax.php"
		})</script> <link
rel='https://api.w.org/' href='https://www.breakingisraelnews.com/wp-json/' /><link
rel='shortlink' href='https://www.breakingisraelnews.com/?p=104972' /><link
rel="alternate" type="application/json+oembed" href="https://www.breakingisraelnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.breakingisraelnews.com%2F104972%2Frecord-setting-crowd-at-passover-sacrifice-reenactment%2F" /><link
rel="alternate" type="text/xml+oembed" href="https://www.breakingisraelnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.breakingisraelnews.com%2F104972%2Frecord-setting-crowd-at-passover-sacrifice-reenactment%2F&#038;format=xml" /> <script type="text/javascript">window._zem_rp_post_id = '104972';
	window._zem_rp_thumbnails = true;
	window._zem_rp_post_title = 'Record+Setting+Crowd+at+Passover+Sacrifice+Reenactment';
	window._zem_rp_post_tags = ['waqf', 'redemption+%28geula%29', 'jerusalem', 'temple+mount', 'passover', 'biblical+news', 'silver', 'jewish', 'men', 'israel', 'aaron', 'jew', 'torah', 'nation', 'event', 'music', 'goat', 'dress', 'passov', 'templ', 'roast'];
	window._zem_rp_static_base_url = 'https://content.zemanta.com/static/';
	window._zem_rp_wp_ajax_url = 'https://www.breakingisraelnews.com/wp-admin/admin-ajax.php';
	window._zem_rp_plugin_version = '1.14';
	window._zem_rp_num_rel_posts = '4';</script> <link
rel="stylesheet" href="https://www.breakingisraelnews.com/wp-content/plugins/related-posts-by-zemanta/static/themes/vertical.css?version=1.14" /><style type="text/css">.related_post_title {
}
ul.related_post {
}
ul.related_post li {
}
ul.related_post li a {
}
ul.related_post li img {
}</style> <script>window.fbAsyncInit = function() {
				FB.init({appId: 628892877122694, version: 'v2.5', status: true, cookie: true, xfbml: true, channelUrl: 'https://www.breakingisraelnews.com/wp-content/themes/abase/modules/facebook-integration/channel.html' });
			};
			(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = "//connect.facebook.net/en_US/all.js";
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script> <meta
property="og:site_name" content="Breaking Israel News | Latest News. Biblical Perspective."><meta
property="og:type" content="article"><meta
property="og:locale" content="en_US"><meta
property="fb:app_id" content="319823531740137"><meta
property="og:url" content="https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/"><meta
property="og:title" content="Record Setting Crowd at Passover Sacrifice Reenactment"><meta
property="og:description" content="Approximately 1,500 people gathered to watch some 20 Kohanim (Jewish men descending from Aaron the Priest) dressed in authentic priestly garments performing the full Passover ceremony as it was in Temple times."><meta
property="og:image" content="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Paschal-offering-2018.jpg"><meta
property="og:image:width" content="660"><meta
property="og:image:height" content="330"><meta
property="article:published_time" content="2018-03-27T12:00:19+00:00"><meta
property="article:modified_time" content="2018-03-27T13:06:52+00:00"><meta
property="article:author" content="https://www.breakingisraelnews.com/author/adam_berkowitz/"><meta
property="article:section" content="Biblical News"><meta
property="article:tag" content="Jerusalem"><meta
property="article:tag" content="Passover"><meta
property="article:tag" content="Redemption (Geula)"><meta
property="article:tag" content="Temple Mount"><meta
property="article:tag" content="Waqf"><link
rel="amphtml" href="https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/amp/"><!--[if lte IE 9]><script src="https://www.breakingisraelnews.com/wp-content/themes/bin-v2/dist/js/scripts.ie.3accdd.js"></script><![endif]--><style type="text/css" id="wp-custom-css">/*
You can add your own CSS here.
.site-navigation .main-navigation .menu-item-87034 a { color: #ddc24f; }
Click the help icon above to learn more.
*/</style></head><body
class="post-template-default single single-post postid-104972 single-format-standard group-blog post-record-setting-crowd-at-passover-sacrifice-reenactment"><noscript><iframe
src="//www.googletagmanager.com/ns.html?id=GTM-K4Q3Z8"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-K4Q3Z8');</script> <div
id="page" class="hfeed site">
<header
id="masthead" class="site-header" role="banner"><div
class="top-menu-wrapper">
<nav
id="top-menu" class="top-menu" role="navigation"><div
class="menu-top-container"><ul
id="menu-top" class="menu"><li
id="menu-item-30414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-30414"><a
href="https://www.breakingisraelnews.com/category/terror-watch/">Terror Watch</a></li><li
id="menu-item-4260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-4260"><a
href="https://www.breakingisraelnews.com/category/middle-east/">Middle East</a></li><li
id="menu-item-65865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-65865"><a
href="https://www.breakingisraelnews.com/category/judea-and-samaria/">Judea and Samaria</a></li><li
id="menu-item-67847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-67847"><a
href="https://www.breakingisraelnews.com/category/inspiration/">Inspiration</a></li><li
id="menu-item-67848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-67848"><a
href="https://www.breakingisraelnews.com/category/start-up-nation/">Start-Up Nation</a></li><li
id="menu-item-66105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-66105"><a
href="https://www.breakingisraelnews.com/category/opinion/">Opinion</a></li><li
id="menu-item-2855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-2855"><a
href="https://www.breakingisraelnews.com/category/videos-inspiration/">Videos</a></li><li
id="menu-item-66103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-66103"><a
href="https://www.breakingisraelnews.com/category/blogs/">Blogs</a></li><li
id="menu-item-23881" class="menu-item menu-item-type-post_type menu-item-object-page menu-depth-0 menu-item-23881"><a
href="https://www.breakingisraelnews.com/support/">Support</a></li><li
id="menu-item-65444" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-65444"><a
href="http://israel365.com/store/?a=4"><b>BIN Store</b></a></li></ul></div>		</nav><div
class="search-block"><div
id="searchform" ><form
action="https://www.breakingisraelnews.com" method="get">
<button
class="search-button" type="submit" value=""></button>
<input
type="text" id="s" name="s" value="" placeholder="Search..." style="width: 106px;"></form></div></div></div><div
class="site-branding"><div
class="site-title"><a
href="https://www.breakingisraelnews.com/" rel="home">Breaking Israel News | Latest News. Biblical Perspective.</a></div></div><nav
id="site-navigation" class="main-navigation" role="navigation">
<span
class="menu-toggle">Menu</span>
<a
href="#content" class="skip-link screen-reader-text" >Skip to content</a><div
class="menu-main-container"><ul
id="menu-main" class="menu"><li
id="menu-item-383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-depth-0 menu-item-383"><a
href="http://www.breakingisraelnews.com/"><b>Home</b></a></li><li
id="menu-item-67845" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-67845"><a
href="http://www.breakingisraelnews.com/tag/end-of-days/">End of Days</a></li><li
id="menu-item-87034" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-87034"><a
href="http://www.breakingisraelnews.com/category/jerusalem/">Jerusalem</a></li><li
id="menu-item-67842" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-67842"><a
href="http://www.breakingisraelnews.com/tag/prophecy/">Bible Prophecy</a></li><li
id="menu-item-65867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-65867"><a
href="https://www.breakingisraelnews.com/category/christian-zionism/"><b>Christian Zionism</b></a></li><li
id="menu-item-65866" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-depth-0 menu-item-65866"><a
href="https://www.breakingisraelnews.com/category/biblical-news/"><b>Biblical News</b></a></li><li
id="menu-item-67846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-67846"><a
href="https://www.breakingisraelnews.com/category/us-israel-relations/">US-Israel</a></li><li
id="menu-item-354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-354"><a
href="https://www.breakingisraelnews.com/category/idf/"><b>IDF</b></a></li><li
id="menu-item-563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-563"><a
href="https://www.breakingisraelnews.com/category/videos/"><b>News Videos</b></a></li><li
id="menu-item-23880" class="menu-item menu-item-type-post_type menu-item-object-page menu-depth-0 menu-item-23880"><a
href="https://www.breakingisraelnews.com/subscribe/"><b>Subscribe</b></a></li></ul></div>		</nav>
</header><div
class="show_in_print" style="text-align: center; display: none; margin-top: 20px;"><img
src="//www.breakingisraelnews.com/wp-content/uploads/2013/06/BreakingIsraelNews1.jpg" width="500"></div><div
id='div-gpt-ad-LB_1' style='margin: 0 auto; width: 970px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-LB_1'); });</script> </div><div
id="content" class="site-content"><div
id="primary" class="content-area">
<main
id="main" class="site-main" role="main">
<article
id="post-104972" class="post-104972 post type-post status-publish format-standard has-post-thumbnail hentry category-biblical-news tag-jerusalem-2 tag-passover tag-redemption-geula tag-temple-mount tag-waqf is-featured">
<header
class="entry-header"><h1 class="entry-title">Record Setting Crowd at Passover Sacrifice Reenactment</h1><div
class="entry-meta">
By <span
class="byline"><span
class="author vcard"><a
href="https://www.breakingisraelnews.com/author/adam_berkowitz/" class="url fn n">Adam Eliyahu Berkowitz</a></span></span>  <span
class="posted-on"><a
href="https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/" rel="bookmark"><time
class="entry-date published updated" title="2018-03-27T16:06:52+00:00" datetime="27 Mar 2018"><span
class="value">March 27, 2018 , 3:00 pm</span></time></a></span></div>
</header><div
class="entry-content" itemscope itemtype ="http://schema.org/NewsArticle"><blockquote
class='verse'><p>&#8220;And when you enter the land that Hashem will give you, as He has promised, you shall observe this rite.&#8221; Exodus 12:25</p></blockquote><div
class="featured-image wp-caption aligncenter"><img
width="660" height="330" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Paschal-offering-2018.jpg" class="attachment-single-leader size-single-leader wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Paschal-offering-2018.jpg 660w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Paschal-offering-2018-300x150.jpg 300w" sizes="(max-width: 660px) 100vw, 660px" data-wpex-post-id="104978" /><p
class="wp-caption-text">Kohanim (Priests/descendants of the High Priest Aaron) reenact the Paschal offering (Credit: Adam Propp)</p></div><p><span
style="font-weight: 400;">The seventh annual reenactment of the </span><i><span
style="font-weight: 400;">Pesach</span></i><span
style="font-weight: 400;"> (Passover) sacrifice took place on Monday, bringing the Nation of Israel ever closer to the Third Temple than before.</span></p><p><span
style="font-weight: 400;">“We can see the Third Temple rising on the horizon,” </span><a
href="https://www.breakingisraelnews.com/80564/third-temple-way-priests-prepare-ritual-shabbat-showbreads-photos/"><span
style="font-weight: 400;">Shimshon Elboim</span></a><span
style="font-weight: 400;">, one of the organizers of the event, told </span><i><span
style="font-weight: 400;">Breaking Israel News</span></i><span
style="font-weight: 400;">. “It used to be just a small group of activists who showed up, but this year, the </span><a
href="https://www.breakingisraelnews.com/86336/photos-priestly-sacrifices-revived-paschal-lamb-offered-god-jerusalem/"><span
style="font-weight: 400;">Passover sacrifice</span></a><span
style="font-weight: 400;"> reenactment went mainstream.”</span></p><p><span
style="font-weight: 400;">Approximately 1,500 people, the largest crowd ever, gathered to watch some 20 </span><i><span
style="font-weight: 400;">Kohanim</span></i><span
style="font-weight: 400;"> (Jewish men descending from Aaron the Priest) dressed in authentic priestly garments performing the full Passover ceremony as it was in Temple times. </span></p><p><span
style="font-weight: 400;">The ceremony was accompanied by blasts from silver horns and other musical accompaniment. Two goats were slaughtered and their blood was collected in silver vessels to be spilled out on a model of the altar. The goats were roasted whole in the manner described in the Torah and served to the Jews gathered to witness the reenactment. </span></p><blockquote><p><span
style="font-weight: 400;">They shall eat the flesh that same night; they shall eat it roasted over the fire, with unleavened bread and with bitter herbs. </span><a
href="https://theisraelbible.com/bible/exodus/chapter-12#verse-8"><span
style="font-weight: 400;">Exodus 12:8</span></a></p></blockquote><p><a
href="https://www.breakingisraelnews.com/99692/double-wonder-hanukkah-miracle-recreated-temple-incense-burned-first-time-2000-years-watch/"><span
style="font-weight: 400;">Mordechai Persoff</span></a><span
style="font-weight: 400;">, head of the </span><span
style="font-weight: 400;">Mikdash Educational Center, </span><span
style="font-weight: 400;">a non-profit organization for education about the Temple, </span><span
style="font-weight: 400;">spoke of the importance in performing the Paschal offering.</span></p><p><span
style="font-weight: 400;">“This is the only sacrifice that if a Jew does not bring it, he receives the most severe punishment: </span><i><span
style="font-weight: 400;">Karet</span></i><span
style="font-weight: 400;">, being cut off from the people,” Persoff explained to </span><i><span
style="font-weight: 400;">Breaking Israel News</span></i><span
style="font-weight: 400;">. “Even though it is a personal sacrifice, it is brought as a nation.”</span></p><p><span
style="font-weight: 400;">Persoff emphasized that this national aspect of the sacrifice was because the very nature of Passover required a consensus of the Jewish people. He referenced the section of Exodus in which Pharaoh offers to let the Children of Israel go to the desert to serve God as long as the kids remain behind. Moses however, refused. </span></p><blockquote><p><a
href="https://theisraelbible.com/glossary/moshe/"><i><span
style="font-weight: 400;">Moshe</span></i></a><span
style="font-weight: 400;"> replied, “We will all go, young and old: we will go with our sons and daughters, our flocks and herds; for we must observe </span><i><span
style="font-weight: 400;">Hashem</span></i><span
style="font-weight: 400;">’s festival.” </span><a
href="https://theisraelbible.com/bible/exodus/chapter-10#verse-9"><span
style="font-weight: 400;">Exodus 10:9</span></a></p></blockquote><p><span
style="font-weight: 400;">Persoff said that the reenactment reflected the national aspect of redemption.</span></p><p><span
style="font-weight: 400;">“Every branch of Judaism from Secular to </span><i><span
style="font-weight: 400;">Haredi</span></i><span
style="font-weight: 400;"> (Ultra-Orthodox), </span><i><span
style="font-weight: 400;">Ashkenazi</span></i><span
style="font-weight: 400;"> and </span><i><span
style="font-weight: 400;">Sephardi</span></i><span
style="font-weight: 400;">, young and old, were all at the event.” Persoff said with enthusiasm. </span></p><p><span
style="font-weight: 400;">“That is how </span><i><span
style="font-weight: 400;">geula</span></i><span
style="font-weight: 400;"> (redemption) happens: when all of Israel comes together. The Temple is, after all, where we get together because it is the source of true peace.”</span></p><p><span
style="font-weight: 400;">Monday’s reenactment of the Passover sacrifice was held at the Davidson Center, an archaeological park on the southern wall of the Temple Mount. The park stands at the foot of the stairs where individuals walked up to bring their sacrifices to the Temple. </span></p><div
id="wpipa-94167-container" data-id="94167" data-variation="none" class="wpipa-container wpipa-align-center"><div
id="wpipa-94167" class="wpipa"style="background-color:#ffffff;color:#ffffff;padding:0px;max-width:600px;"><p></p><div
style="width: 100%;"><div
id="div-gpt-ad-in_article" style="width: 650px; margin: 0 auto;"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-in_article'); });</script></div></div></div></div><h2><span
style="font-weight: 400;">Reenacting the ‘House of Prayer For All Nations’</span></h2><p><span
style="font-weight: 400;">In previous years, the organizers received permits to hold the ceremony at this particular location only to have the </span><a
href="https://www.breakingisraelnews.com/101527/holiest-police-world-paving-way-third-temple/"><span
style="font-weight: 400;">Israeli police</span></a><span
style="font-weight: 400;"> cancel the permit over security concerns. Previous reenactments were therefore held much further away from the Temple Mount. </span></p><p><span
style="font-weight: 400;">“Many Arab language media carried threats from the Waqf (Muslim authority) should the </span><i><span
style="font-weight: 400;">Korban Pesach</span></i><span
style="font-weight: 400;"> (Passover sacrifice) reenactment take place,” Rabbi Hillel Weiss, spokesman for the nascent </span><a
href="https://www.breakingisraelnews.com/104480/sanhedrin-calls-on-arabs-to-take-their-role-in-third-temple-as-prophesized-by-isaiah/"><i><span
style="font-weight: 400;">Sanhedrin</span></i></a><span
style="font-weight: 400;">, told </span><i><span
style="font-weight: 400;">Breaking Israel News</span></i><span
style="font-weight: 400;">. </span></p><p><span
style="font-weight: 400;">“But the government decided not to give in to the rule of violence. The permit for the event was signed by Jerusalem Mayor Nir Barkat, and the police should be praised for their role in helping Jerusalem become a House of Prayer for all Nations.”</span></p><p><span
style="font-weight: 400;">Many prominent rabbis attended, including Rabbi Aryeh Stern, the chief rabbi of Jerusalem as well as Rabbi Yehudah Glick, a Member of Knesset in Prime Minister Benjamin Netanyahu’s Likud Party and long-time advocate for Jewish rights on the Temple Mount. </span></p><p><span
style="font-weight: 400;">Citing Rabbi Shlomo Yitzchaki, the preeminent 11th century French Torah scholar who is known by the acronym, “</span><a
href="https://www.breakingisraelnews.com/101958/russian-media-report-biblical-bombshell-siberian-river-turns-crimson/#EcCIhU8OpxgIM8hh.97"><i><span
style="font-weight: 400;">Rashi</span></i></a><span
style="font-weight: 400;">,” Rabbi Weiss explained that the return of the Paschal offering is a significant marker in the Jews’ return to Israel</span></p><p><span
style="font-weight: 400;">“According to </span><i><span
style="font-weight: 400;">Rashi</span></i><span
style="font-weight: 400;">, the Passover sacrifice was only performed once in the desert,” Rabbi Weiss explained. “Because of its nationalistic nature, it was not offered again until the Jews entered the land of Israel. </span></p><p><span
style="font-weight: 400;">“The Jewish return to Israel and the end of exile will not be complete until the Passover sacrifice is reinstated in its proper place and at its proper time.”</span></p><div
class='shareaholic-canvas' data-app='share_buttons' data-title='Record Setting Crowd at Passover Sacrifice Reenactment' data-link='https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/' data-summary='Approximately 1,500 people gathered to watch some 20 Kohanim (Jewish men descending from Aaron the Priest) dressed in authentic priestly garments performing the full Passover ceremony as it was in Temple times.' data-app-id='27702068' data-app-id-name='post_below_content'></div></p><div
id="wpipa-94169-container" data-id="94169" data-variation="none" class="wpipa-container wpipa-align-center"><div
id="wpipa-94169" class="wpipa"style="background-color:#ffffff;color:#ffffff;padding:0px;max-width:600px;"><p></p><div
style="width: 100%;"><div
id='div-gpt-ad-under_article' style="width: 300px; margin: 0 auto;"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-under_article'); });</script> </div></div></div></div><div
id='div-gpt-ad-1487602151590-4' style="max-width: 300px; margin: 0px auto;"> <script src='https://www.googletagservices.com/tag/js/gpt.js'>googletag.pubads().definePassback('/264857099/BIN/ROS/HP_Interstitial', [1, 1]).setTargeting('BIN_pageType', 'article').display();</script> </div><div
id="rcjsload_f535c7"></div> <script type="text/javascript">(function() {

var referer="";try{if(referer=document.referrer,"undefined"==typeof referer||""==referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);

var rcel = document.createElement("script");

rcel.id = 'rc_' + Math.floor(Math.random() * 1000);

rcel.type = 'text/javascript';

rcel.src = "https://trends.revcontent.com/serve.js.php?w=87653&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;

rcel.async = true;

var rcds = document.getElementById("rcjsload_f535c7"); rcds.appendChild(rcel);

})();</script> 
<interaction
data-token="59abdcfd645666010023863d" data-context="true" data-tags="" data-fallback="true"></interaction><div
id="rcjsload_e5fbeb"></div> <script type="text/javascript">(function() {
function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}
ad_block_test(function(is_blocked){
var widget_id = 79500;
if (is_blocked === true) {
widget_id = 86470;
}
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth) +"&referer="+referer + '&is_blocked=' + is_blocked;
rcel.async = true;
var rcds = document.getElementById("rcjsload_e5fbeb"); rcds.appendChild(rcel);
});
})();</script> <div
style="width: 100%"><style type="text/css">/*<![CDATA[*/#mc_embed_signup{background-color:#99cdfc; clear:left; font:14px Helvetica,Arial,sans-serif; border-radius: 5px; padding: 5px 10px 10px }<br />	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.<br />	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */<br />/*]]>*/</style><div
id="mc_embed_signup" style="width: 425px; margin: 0 auto;"><form
id="mc-embedded-subscribe-form" class="validate" action="https://breakingisraelnews.us7.list-manage.com/subscribe/post?u=5c0f59e0cd1aba49e650622c4&amp;id=b6d3627f72" target="_blank" method="post" name="mc-embedded-subscribe-form" novalidate=""><div
id="mc_embed_signup_scroll"><h2 style="margin-top: 0px;">Subscribe to our mailing list</h2><div
class="mc-field-group"><input
id="mce-EMAIL" class="required email" style="width: 400px; margin-bottom: 0px;" name="EMAIL" type="email" value="" placeholder="Enter your email address!" /></div><div
class="mc-field-group" style="display: none;"><label
for="mce-FNAME">First Name </label>
<input
id="mce-FNAME" class="" name="FNAME" type="text" value="" /></div><div
class="mc-field-group" style="display: none;"><label
for="mce-LNAME">Last Name </label>
<input
id="mce-LNAME" class="" name="LNAME" type="text" value="" /></div><div
class="mc-field-group input-group" style="display: none;"><strong>Breaking Israel News Daily Edition </strong><ul><li><input
id="mce-group[1]-1-0" checked="checked" name="group[1][1]" type="checkbox" value="1" /><label
for="mce-group[1]-1-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Breaking Israel News Evening Edition </strong><ul><li><input
id="mce-group[49]-49-0" checked="checked" name="group[49][4096]" type="checkbox" value="4096" /><label
for="mce-group[49]-49-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Promotions </strong><ul><li><input
id="mce-group[57]-57-0" name="group[57][65536]" type="checkbox" value="65536" /><label
for="mce-group[57]-57-0">No Promotions</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Today's Top Israel Opinion and Blogs </strong><ul><li><input
id="mce-group[41]-41-0" name="group[41][1024]" type="checkbox" value="1024" /><label
for="mce-group[41]-41-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>IDF News Daily Digest </strong><ul><li><input
id="mce-group[5]-5-0" name="group[5][2]" type="checkbox" value="2" /><label
for="mce-group[5]-5-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Jerusalem News Daily Digest </strong><ul><li><input
id="mce-group[9]-9-0" name="group[9][4]" type="checkbox" value="4" /><label
for="mce-group[9]-9-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Best of Israel English Radio </strong><ul><li><input
id="mce-group[45]-45-0" name="group[45][2048]" type="checkbox" value="2048" /><label
for="mce-group[45]-45-0">Stay Infromed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Today's Top News Videos </strong><ul><li><input
id="mce-group[13]-13-0" name="group[13][8]" type="checkbox" value="8" /><label
for="mce-group[13]-13-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Middle East News Daily Digest </strong><ul><li><input
id="mce-group[25]-25-0" name="group[25][64]" type="checkbox" value="64" /><label
for="mce-group[25]-25-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Judea and Samaria News Daily Digest </strong><ul><li><input
id="mce-group[37]-37-0" name="group[37][512]" type="checkbox" value="512" /><label
for="mce-group[37]-37-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Israel Technology News Daily Digest </strong><ul><li><input
id="mce-group[33]-33-0" name="group[33][256]" type="checkbox" value="256" /><label
for="mce-group[33]-33-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Biblical Zionism News Daily Digest </strong><ul><li><input
id="mce-group[29]-29-0" name="group[29][128]" type="checkbox" value="128" /><label
for="mce-group[29]-29-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Jewish World News Daily Digest </strong><ul><li><input
id="mce-group[21]-21-0" name="group[21][32]" type="checkbox" value="32" /><label
for="mce-group[21]-21-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Israel Inspiration News Daily Digest </strong><ul><li><input
id="mce-group[17]-17-0" name="group[17][16]" type="checkbox" value="16" /><label
for="mce-group[17]-17-0">Stay Informed</label></li></ul></div><div
class="mc-field-group input-group" style="display: none;"><strong>Jerusalem Covenant </strong><ul><li><input
id="mce-group[69]-69-0" name="group[69][1048576]" type="checkbox" value="1048576" /><label
for="mce-group[69]-69-0">Yes</label></li></ul></div><div
id="mce-responses" class="clear"></div><div
style="position: absolute; left: -5000px;" aria-hidden="true"><input
tabindex="-1" name="b_5c0f59e0cd1aba49e650622c4_b6d3627f72" type="text" value="" /></div>
<input
id="mc-embedded-subscribe" class="button" style="font-size: 12px; margin: 5px 0px 0px;" name="subscribe" type="submit" value="Subscribe" onclick="openInNewTab();" /></div></form></div> <script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[3]='UBPAGEID';ftypes[3]='text';fnames[4]='UBVARIANT';ftypes[4]='text';fnames[5]='UBDATE';ftypes[5]='date';fnames[6]='MMERGE6';ftypes[6]='address';fnames[7]='SIGNUP';ftypes[7]='text';}(jQuery));var $mcj = jQuery.noConflict(true);
  function openInNewTab() {
  var win = window.open('https://www.breakingisraelnews.com/thank-you-subscribe/', '_blank');
  win.focus();
}</script> </div></div><footer
class="entry-footer"><div
class="article-footer-tags"><div
class="entry-tags">Tagged with: <a
href="https://www.breakingisraelnews.com/tag/jerusalem-2/" rel="tag">Jerusalem</a> <a
href="https://www.breakingisraelnews.com/tag/passover/" rel="tag">Passover</a> <a
href="https://www.breakingisraelnews.com/tag/redemption-geula/" rel="tag">Redemption (Geula)</a> <a
href="https://www.breakingisraelnews.com/tag/temple-mount/" rel="tag">Temple Mount</a> <a
href="https://www.breakingisraelnews.com/tag/waqf/" rel="tag">Waqf</a></div></div>
</footer>
</article><div
id="heyoyaDiv"></div><script type="text/javascript" src="//commerce-static.heyoya.com/b2b/b2b_settings.hey?affId=yhGCard6ll"></script> </main></div><div
id="secondaryRight" class="widget-area mid-size" role="complementary"><div
class="widget-area-inner">
<aside
id="custom_html-8" class="widget_text widget widget_custom_html"><div
class="textwidget custom-html-widget"><div
id='div-gpt-ad-MPU_1'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-MPU_1'); });</script> </div></div></aside>
<aside
id="category_posts_widget-4" class="widget widget_category_posts"><h2 class="widget-title"><span>Latest News		</span></h2><ul><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104930/french-authorities-arrest-two-suspects-in-holocaust-survivors-murder/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-d’écran-2018-03-26-à-15-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-d’écran-2018-03-26-à-15-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-d’écran-2018-03-26-à-15-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="104931" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104930/french-authorities-arrest-two-suspects-in-holocaust-survivors-murder/">French Authorities Arrest Two Suspects in Holocaust-Survivor’s Murder</a><time
class="article-date">March 27, 2018 , 8:00 am</time></div></li><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104924/first-settlement-in-25-years-inhabited-with-evacuees-from-amona/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/amona-evacuees-880x495-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/amona-evacuees-880x495-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/amona-evacuees-880x495-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="104928" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104924/first-settlement-in-25-years-inhabited-with-evacuees-from-amona/">First &#8216;Settlement&#8217; in 25 Years Inhabited With Evacuees From Amona</a><time
class="article-date">March 27, 2018 , 7:00 am</time></div></li><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104909/freedom-coins-from-first-jewish-revolt-against-rome-discovered-in-temple-mount-cave/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Freedom-Coins-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Freedom-Coins-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Freedom-Coins-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="104912" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104909/freedom-coins-from-first-jewish-revolt-against-rome-discovered-in-temple-mount-cave/">‘Freedom Coins’ From First Jewish Revolt Against Rome Discovered in Temple Mount Cave</a><time
class="article-date">March 26, 2018 , 5:00 pm</time></div></li><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104874/israels-iron-dome-triggered-by-machine-gun-fire-in-gaza-strip/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2015/10/Iron-Dome-Intercepts-Rockets-from-the-Gaza-Strip-cropped-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2015/10/Iron-Dome-Intercepts-Rockets-from-the-Gaza-Strip-cropped-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2015/10/Iron-Dome-Intercepts-Rockets-from-the-Gaza-Strip-cropped-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="51125" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104874/israels-iron-dome-triggered-by-machine-gun-fire-in-gaza-strip/">Israel&#8217;s Iron Dome Triggered by Machine-Gun Fire in Gaza Strip</a><time
class="article-date">March 26, 2018 , 10:00 am</time></div></li><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104864/grave-of-biblical-figure-caleb-found-desecreated-with-swastikas/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Calebs-Tomb-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Calebs-Tomb-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Calebs-Tomb-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="104873" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104864/grave-of-biblical-figure-caleb-found-desecreated-with-swastikas/">Grave of Biblical Figure Caleb Found Desecrated With Swastikas</a><time
class="article-date">March 26, 2018 , 9:00 am</time></div></li></ul>
</aside>				<aside
id="custom_html-7" class="widget_text widget widget_custom_html"><div
class="textwidget custom-html-widget"><div
id='div-gpt-ad-SKY_1'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-SKY_1'); });</script> </div></div></aside><div
id='div-gpt-ad-1487602151590-1'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1487602151590-1'); });</script> </div>
<aside
id="author-custom-widget-9" class="widget author-custom"><h2 class="widget-title"><span>About the Author</span></h2><div ><img
class="alignleft size-full wp-image-839" alt="Adam_Eliyahu_Berkowitz"src="//www.breakingisraelnews.com/wp-content/uploads/2015/06/Adam-Berkowitz1.jpg" width="150" height="150" /></a><em>Adam Eliyahu Berkowitz is a features writer for Breaking Israel News. He made Aliyah to Israel in 1991 and served in the IDF as a combat medic. Berkowitz studied Jewish law and received rabbinical ordination in Israel. He has worked as a freelance writer and two works of fiction, The Hope Merchant and Dolphins on the Moon, are available on Amazon. He lives in the Golan Heights with his wife and their four children.</em></div><div
class="clear">&nbsp;</div></aside><aside
id="author_post_widget-10" class="widget widget_author_posts"><h2 class="widget-title"><span>By Adam Eliyahu Berkowitz</span></h2><ul><li><a
href="https://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/" rel="bookmark" title="Record Setting Crowd at Passover Sacrifice Reenactment">Record Setting Crowd at Passover Sacrifice Reenactment</a></li><li><a
href="https://www.breakingisraelnews.com/104889/can-non-jews-eat-lab-grown-meat/" rel="bookmark" title="Can Non-Jews Eat Lab-Grown Meat?">Can Non-Jews Eat Lab-Grown Meat?</a></li><li><a
href="https://www.breakingisraelnews.com/104771/un-human-rights-council-5-anti-israel-resolutions-call-for-arms-embargo-haley-stands-strong/" rel="bookmark" title="As UN Human Rights Council Calls for Israel Arms Embargo, Haley Stands Strong">As UN Human Rights Council Calls for Israel Arms Embargo, Haley Stands Strong</a></li></ul>
<a
href="https://www.breakingisraelnews.com/author/adam_berkowitz/"> All (1504)</a>
</aside><aside
id="custom_html-10" class="widget_text widget widget_custom_html"><div
class="textwidget custom-html-widget"><div
id='div-gpt-ad-SKY_2'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-SKY_2'); });</script> </div></div></aside><aside
id="custom_html-9" class="widget_text widget widget_custom_html"><div
class="textwidget custom-html-widget"><div
id='div-gpt-ad-MPU_2'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-MPU_2'); });</script> </div></div></aside>
<aside
id="category_posts_widget-3" class="widget widget_category_posts"><h2 class="widget-title"><span>Viral Israel Videos		</span></h2><ul><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104965/israel-stands-with-you-netanyahu-tells-french-foreign-minister-after-terror-attack/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-YouTube-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-YouTube-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-YouTube-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="104967" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104965/israel-stands-with-you-netanyahu-tells-french-foreign-minister-after-terror-attack/">&#8216;Israel Stands With You,&#8217; Netanyahu tells French Foreign Minister After Terror Attack</a></div></li><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104876/netanyahu-celebrates-first-direct-flight-from-india-over-saudi-airspace/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-Netanyahu-3-25-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-Netanyahu-3-25-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-Netanyahu-3-25-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="104878" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104876/netanyahu-celebrates-first-direct-flight-from-india-over-saudi-airspace/">Netanyahu Celebrates First Direct Flight From India Over Saudi Airspace</a></div></li><li><a
class="article-thumb" href="https://www.breakingisraelnews.com/104801/i-feel-the-change-in-the-un-israeli-ambassador-danny-danon/"><img
width="55" height="55" src="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-Danny-Danon-1-55x55.jpg" class="attachment-tie-small size-tie-small wpexpro-image wp-post-image" alt="" srcset="https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-Danny-Danon-1-55x55.jpg 55w, https://www.breakingisraelnews.com/wp-content/uploads/2018/03/Capture-Danny-Danon-1-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" data-wpex-post-id="104803" /></a><div><a
class="article-title" href="https://www.breakingisraelnews.com/104801/i-feel-the-change-in-the-un-israeli-ambassador-danny-danon/">&#8216;I Feel The Change&#8217; in the UN: Israeli Ambassador Danny Danon</a></div></li></ul>
</aside>				<aside
id="custom_html-11" class="widget_text widget widget_custom_html"><div
class="textwidget custom-html-widget"><div
id='div-gpt-ad-MPU_3'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-MPU_3'); });</script> </div></div></aside></div></div><div
class="holder"></div></div><footer
id="footer" class="site-footer" role="contentinfo"><div
class="inner-footer"><div
class="site-footer-left" role="contentinfo"><div
class="widget-area-inner">
<aside
id="text-7" class="widget widget_text"><h2 class="widget-title"><span>About BIN</span></h2><div
class="textwidget"><p><a
href="https://www.breakingisraelnews.com">Breaking Israel News</a> offers a fresh and Biblical perspective on the latest news from Israel and the Middle East. Our bias is not liberal nor conservative - just Biblical.</p><p><a
href="https://www.breakingisraelnews.com/about-us">Our Staff</a></p></div>
</aside><aside
id="text-8" class="widget widget_text"><h2 class="widget-title"><span>Contact BIN</span></h2><div
class="textwidget"><p>We would love to hear from you.</p><p><a
href="https://www.breakingisraelnews.com/contact-us">Contact Us</a></p></div>
</aside></div></div><div
class="site-footer-right" role="contentinfo"><div
class="widget-area-inner">
<aside
id="text-9" class="widget widget_text"><h2 class="widget-title"><span>Advertise with BIN</span></h2><div
class="textwidget"><p>Reach our growing audience of staunch Jewish and Christian supporters of Israel.  <a
href="https://www.breakingisraelnews.com/advertise-with-us">Inquire about our rates.</a></p></div>
</aside><aside
id="text-10" class="widget widget_text"><h2 class="widget-title"><span>Contribute to BIN</span></h2><div
class="textwidget"><p>If you are passionate about Israel and interested in featuring your thoughts on our site, <a
href="https://www.breakingisraelnews.com/blog-for-us">contact us</a> for more information.</p><p><a
href="https://www.breakingisraelnews.com/our-contributors">Our Contributors</a></p></div>
</aside></div></div></div><div
class="footer-bottom"><div
class="container"><div
class="alignright">
<a
href="//www.breakingisraelnews.com/sitemap">Sitemap</a> | <a
href="//www.breakingisraelnews.com/privacy-policy">Privacy Policy</a> | <a
href="//www.breakingisraelnews.com/copyright-policy/">Copyright Policy</a></div><div
class="social-icons icon_16">
<a
href="//www.breakingisraelnews.com/feed/" class="ttip" target="_blank" original-title="Rss"><img
src="//www.breakingisraelnews.com/wp-content/themes/sahifa/images/socialicons/rss.png" alt="RSS"></a></div><div
class="alignleft">
© Copyright 2013 - 2018, All Rights Reserved</div></div></div></footer><div
class="foot-wrapper"><div
class="standard-foot"><div
class="space1">&nbsp;</div><div
class="logoholder"><a
href="https://www.israel365.com"><img
src="https://www.breakingisraelnews.com/wp-content/uploads/2016/09/Israel365-logo-dark-2.png" alt="israel365 logo" /></a></div><div
class="space2">&nbsp;</div><div
class="logoholder"><a
href="http://www.theisraelbible.com"><img
src="https://www.breakingisraelnews.com/wp-content/uploads/2016/09/tib-footer-bin.jpg" alt="theisraelbiblelogo" /></a></div><div
class="space2">&nbsp;</div><div
class="logoholder"><a
href="http://www.israelmedianetwork.com"><img
src="https://www.breakingisraelnews.com/wp-content/uploads/2016/09/IMN-Logo-TextSide-2.png" alt="israel media network logo" /></a></div><div
class="space1">&nbsp;</div></div></div></div>
<?php// } ?>
 <script type='text/javascript'>/*  */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.breakingisraelnews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/*  */</script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?v=3accdd'></script> <script type='text/javascript'>/*<![CDATA[*//*  */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"319823531740137"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/*  *//*]]>*/</script> <script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="https:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script> <script type='text/javascript' src='https://www.breakingisraelnews.com?v=3accdd'></script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-includes/js/underscore.min.js?v=3accdd'></script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-content/themes/bin-v2/dist/js/scripts.libs.3accdd.js?v=3accdd'></script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-content/themes/bin-v2/dist/js/scripts.3accdd.js?v=3accdd'></script> <script type='text/javascript'>/*  */
var wpipaViews = {"url":"https:\/\/www.breakingisraelnews.com\/wp-admin\/admin-ajax.php"};
/*  */</script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-content/plugins/mts-wp-in-post-ads/public/js/wp-in-post-ads-views.js?v=3accdd'></script> <script type='text/javascript' src='https://www.breakingisraelnews.com/wp-includes/js/wp-embed.min.js?v=3accdd'></script> <div
id="fb-root"></div><script type="text/javascript">jQuery(function() {
    jQuery("a:not([href*=breakingisraelnews\\.]):not([href^=#]):not([href^='']):not([href*=googleservices]):not([href*=pagead]), a[href*=feeds\\.breakingisraelnews], a[href$=\\/feed\\/], a[href^=mail]").on('click',function(e){
        var url = jQuery(this).attr("href");
        if (url && e.currentTarget.host != window.location.host) {
            _gaq.push(['_trackEvent', "Outbound Link", e.currentTarget.host, url, 0, 0])
            if (jQuery(this).attr("target") != '_blank' && jQuery(this).attr("href") != '' && !(e.metaKey || e.ctrlKey)){
                e.preventDefault();
                setTimeout('document.location = "' + url + '"', 100);
            }
        }
    });
});

jQuery('.ubm_premium_banner').click(function() {
	__ga('send', 'event', 'Ads', 'Click', 'CustomAds');
	__gaTracker('send', 'event', 'Ads', 'Clicks', 'CustomAds');
});</script> <script>var pwidget_config = {
    trackAddressBar: true,
    defaults: {
    	url: "http://www.breakingisraelnews.com/104972/record-setting-crowd-at-passover-sacrifice-reenactment/"
    }
};</script> <script>// MY CUSTOM SCRIPTS
jQuery('#heyoyaDiv').before('<em>Breaking Israel News offers news from Israel from an Orthodox Jewish perspective to both Jewish and Christian readers. We encourage open dialogue and welcome respectful questions. However, since we are an Orthodox Jewish site, our content is meant to stay focused on our shared heritage of the Hebrew Bible, and not Christian Scripture. We ask that our readers follow these guidelines when commenting on our site: <ul><li>&bull; Comments must be respectful and non-offensive.</li><li>&bull; Comments must not proselytize in any way.</li><li>&bull; Comments should stay focused on the Hebrew Bible and not refer to Christian Scripture.</li></ul>Any comments that do not comply with these guidelines may be removed from the site. Repeated violations of the guidelines could result in users being banned from commenting.</em>');</script> <script src="https://s.po.st/static/v3/post-widget.js#publisherKey=3441d986llp5sbidnrvc" type="text/javascript"></script> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script> <div
id="fb-root"></div><div
id='div-gpt-ad-FI_tag'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-FI_tag'); });</script> </div></body></html>