<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if (IE 9)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie10"><![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->
<head>
  <!-- Google Tag Manager | This is commented out since we switched to a plugin
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-K4Q3Z8');</script>
  End Google Tag Manager -->
    <script type="text/javascript" src="//static.apester.com/js/sdk/v2.0/apester-javascript-sdk.min.js" async></script>
  <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
  <script async='async' src="https://www.googletagservices.com/tag/js/gpt.js"></script>



<!--old google code used to be here, below is the new code as of 5/27/2019 | old code can be found in private_html on kinsta-->






<meta name="author" content="DAVID SUISSA" />

<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta property="fb:pages" content="164071980437584" />
<title>Can We Keep the Focus on George Floyd’s Killer? - Israel News</title>
<link rel="profile" href="//gmpg.org/xfn/11">
<link rel="pingback" href="https://www.breakingisraelnews.com/xmlrpc.php">
<link rel="shortcut icon" href="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2013/06/favicon.png">
<link rel="amphtml" href="https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/amp/">
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
<!-- This site is optimized with the Yoast SEO Premium plugin v12.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Instead of talking about police violence, we’re talking more about protestor violence that makes for dramatic media images."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.jns.org/opinion/can-we-keep-the-focus-on-george-floyds-killer/" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.breakingisraelnews.com/#organization","name":"Breaking Israel News","url":"https://www.breakingisraelnews.com/","sameAs":["https://www.facebook.com/BreakingIsraelNews","https://twitter.com/BINalerts"],"logo":{"@type":"ImageObject","@id":"https://www.breakingisraelnews.com/#logo","url":"https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2019/04/BreakingIsraelNews-longstripe.jpg","width":627,"height":79,"caption":"Breaking Israel News"},"image":{"@id":"https://www.breakingisraelnews.com/#logo"}},{"@type":"WebSite","@id":"https://www.breakingisraelnews.com/#website","url":"https://www.breakingisraelnews.com/","name":"Breaking Israel News | Latest News. Biblical Perspective.","publisher":{"@id":"https://www.breakingisraelnews.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.breakingisraelnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#primaryimage","url":"https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931.jpg","width":660,"height":330},{"@type":"WebPage","@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#webpage","url":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/","inLanguage":"en-US","name":"Can We Keep the Focus on George Floyd\u2019s Killer? - Israel News","isPartOf":{"@id":"https://www.breakingisraelnews.com/#website"},"primaryImageOfPage":{"@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#primaryimage"},"datePublished":"2020-06-02T05:00:30+00:00","dateModified":"2020-06-02T03:05:48+00:00","description":"Instead of talking about police violence, we\u2019re talking more about protestor violence that makes for dramatic media images.","breadcrumb":{"@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.breakingisraelnews.com/category/uncategorized/","url":"https://www.breakingisraelnews.com/category/uncategorized/","name":"Uncategorized"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/","url":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/","name":"Can We Keep the Focus on George Floyd\u2019s Killer?"}}]},{"@type":"Article","@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#article","isPartOf":{"@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#webpage"},"author":{"@id":"https://www.breakingisraelnews.com/#/schema/person/e0d5cbf55217775c6da014485dd67857"},"headline":"Can We Keep the Focus on George Floyd\u2019s Killer?","datePublished":"2020-06-02T05:00:30+00:00","dateModified":"2020-06-02T03:05:48+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#webpage"},"publisher":{"@id":"https://www.breakingisraelnews.com/#organization"},"image":{"@id":"https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/#primaryimage"},"keywords":"George Floyd,Israel,United States (US)","articleSection":""},{"@type":["Person"],"@id":"https://www.breakingisraelnews.com/#/schema/person/e0d5cbf55217775c6da014485dd67857","name":"DAVID SUISSA","image":{"@type":"ImageObject","@id":"https://www.breakingisraelnews.com/#authorlogo","url":"https://secure.gravatar.com/avatar/313999239790eceda9ac154c8b10ceac?s=96&d=mm&r=g","caption":"DAVID SUISSA"},"sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel='dns-prefetch' href='//a.opmnstr.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel="alternate" type="application/rss+xml" title="Breaking Israel News | Latest News. Biblical Perspective. &raquo; Feed" href="https://www.breakingisraelnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Breaking Israel News | Latest News. Biblical Perspective. &raquo; Comments Feed" href="https://www.breakingisraelnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Breaking Israel News | Latest News. Biblical Perspective. &raquo; Can We Keep the Focus on George Floyd’s Killer? Comments Feed" href="https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/feed/" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://mk0breakingisralps2c.kinstacdn.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://mk0breakingisralps2c.kinstacdn.com/wp-content/plugins/add-to-any/addtoany.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='abase-stylesheet-css'  href='https://mk0breakingisralps2c.kinstacdn.com/wp-content/themes/bin-v2/dist/css/style.css' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='abase-ie-only-css'  href='https://mk0breakingisralps2c.kinstacdn.com/wp-content/themes/bin-v2/dist/css/ie.css' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-content/plugins/add-to-any/addtoany.min.js'></script>
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.opmnstr.com/app/js/api.min.js?v=3accdd'></script>
	<script>
		// Declare the aBase namespace
		aBase = jQuery.extend({},{
			authenticated: 0,
			template_url: "https://www.breakingisraelnews.com/wp-content/themes/bin-v2", // A path to the theme template from root
			home_url: "https://www.breakingisraelnews.com",
			ajax_url: "https://www.breakingisraelnews.com/wp-admin/admin-ajax.php"
		})
	</script>
	
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>


<!-- This site uses the Open External Links in a New Window plugin v1.4 by WebFactory Ltd. Download it for free at https://wordpress.org/extend/plugins/open-external-links-in-a-new-window/ -->
<script type="text/javascript">//<![CDATA[
  function external_links_in_new_windows_loop() {
    if (!document.links) {
      document.links = document.getElementsByTagName('a');
    }
    var change_link = false;
    var force = '';
    var ignore = '';

    for (var t=0; t<document.links.length; t++) {
      var all_links = document.links[t];
      change_link = false;
      
      if(document.links[t].hasAttribute('onClick') == false) {
        // forced if the address starts with http (or also https), but does not link to the current domain
        if(all_links.href.search(/^http/) != -1 && all_links.href.search('www.breakingisraelnews.com') == -1 && all_links.href.search(/^#/) == -1) {
          // console.log('Changed ' + all_links.href);
          change_link = true;
        }
          
        if(force != '' && all_links.href.search(force) != -1) {
          // forced
          // console.log('force ' + all_links.href);
          change_link = true;
        }
        
        if(ignore != '' && all_links.href.search(ignore) != -1) {
          // console.log('ignore ' + all_links.href);
          // ignored
          change_link = false;
        }

        if(change_link == true) {
          // console.log('Changed ' + all_links.href);
          document.links[t].setAttribute('onClick', 'javascript:window.open(\''+all_links.href+'\'); return false;');
          document.links[t].removeAttribute('target');
        }
      }
    }
  }
  
  // Load
  function external_links_in_new_windows_load(func)
  {  
    var oldonload = window.onload;
    if (typeof window.onload != 'function'){
      window.onload = func;
    } else {
      window.onload = function(){
        oldonload();
        func();
      }
    }
  }

  external_links_in_new_windows_load(external_links_in_new_windows_loop);
  //]]></script>

<script type="text/javascript">
	window._zem_rp_post_id = '151245';
	window._zem_rp_thumbnails = true;
	window._zem_rp_post_title = 'Can+We+Keep+the+Focus+on+George+Floyd%E2%80%99s+Killer%3F';
	window._zem_rp_post_tags = ['israel', 'united+states+%28us%29', 'george+floyd', 'floyd', 'tip', 'death', 'brown', 'eric', 'minneapoli', 'movi', 'derek', 'polic', 'michael', 'ferguson', 'cop', 'georg', 'york', 'abus'];
	window._zem_rp_static_base_url = 'https://content.zemanta.com/static/';
	window._zem_rp_wp_ajax_url = 'https://www.breakingisraelnews.com/wp-admin/admin-ajax.php';
	window._zem_rp_plugin_version = '1.14';
	window._zem_rp_num_rel_posts = '4';
</script>
<link rel="stylesheet" href="https://mk0breakingisralps2c.kinstacdn.com/wp-content/plugins/related-posts-by-zemanta/static/themes/vertical.css?version=1.14" />
<style type="text/css">
.related_post_title {
}
ul.related_post {
}
ul.related_post li {
}
ul.related_post li a {
}
ul.related_post li img {
}</style>

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["uncategorized"],"pageAttributes":["george-floyd","israel","united-states"],"pagePostAuthor":"DAVID SUISSA"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-K4Q3Z8');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->		<!--meta property="fb:admins" content="628892877122694" /-->
		<script>
			window.fbAsyncInit = function() {
				FB.init({appId: 628892877122694, version: 'v2.5', status: true, cookie: true, xfbml: true, channelUrl: 'https://www.breakingisraelnews.com/wp-content/themes/abase/modules/facebook-integration/channel.html' });
			};
			(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = "//connect.facebook.net/en_US/all.js";
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));
		</script>
	<meta property="og:site_name" content="Breaking Israel News | Latest News. Biblical Perspective.">
<meta property="og:type" content="article">
<meta property="og:locale" content="en_US">
<meta property="og:url" content="https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/">
<meta property="og:title" content="Can We Keep the Focus on George Floyd’s Killer?">
<meta property="og:description" content="Instead of talking about police violence, we’re talking more about protestor violence that makes for dramatic media images.">
<meta property="og:image" content="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931.jpg">
<meta property="og:image:width" content="660">
<meta property="og:image:height" content="330">
<meta property="article:published_time" content="2020-06-02T05:00:30+00:00">
<meta property="article:modified_time" content="2020-06-02T03:05:48+00:00">
<meta property="article:author" content="https://www.breakingisraelnews.com/author/david-suissa/">
<meta property="article:tag" content="George Floyd">
<meta property="article:tag" content="Israel">
<meta property="article:tag" content="United States (US)">
<!--[if lte IE 9]><script src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/themes/bin-v2/dist/js/scripts.ie.3accdd.js"></script><![endif]-->		<style type="text/css" id="wp-custom-css">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</style>
		<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>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</script>


</head>

<body class="post-template-default single single-post postid-151245 single-format-standard group-blog post-can-we-keep-the-focus-on-george-floyds-killer-opinion">
<!-- Google Tag Manager | Hidden since we switched to a plugin installation
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-K4Q3Z8"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
End Google Tag Manager -->

<div id="page" class="hfeed site">
	<header id="masthead" class="site-header" role="banner">
	<div class="top-menu-wrapper">
		<nav id="top-menu" class="top-menu" role="navigation">
			<div class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-30414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-30414"><a href="https://www.breakingisraelnews.com/category/terror-watch/">Terror Watch</a></li>
<li id="menu-item-4260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-4260"><a href="https://www.breakingisraelnews.com/category/middle-east/">Middle East</a></li>
<li id="menu-item-65865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-65865"><a href="https://www.breakingisraelnews.com/category/judea-and-samaria/">Biblical Heartland</a></li>
<li id="menu-item-67847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-67847"><a href="https://www.breakingisraelnews.com/category/inspiration/">Inspiration</a></li>
<li id="menu-item-66105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-66105"><a href="https://www.breakingisraelnews.com/category/opinion/">Opinion</a></li>
<li id="menu-item-2855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-2855"><a href="https://www.breakingisraelnews.com/category/videos-inspiration/">Videos</a></li>
<li id="menu-item-23881" class="menu-item menu-item-type-post_type menu-item-object-page menu-depth-0 menu-item-23881"><a href="https://www.breakingisraelnews.com/support/">Support</a></li>
<li id="menu-item-120759" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-120759"><a href="https://israel365.com/store">Shop Israel</a></li>
<li id="menu-item-65444" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-65444"><a href="https://www.breakingisraelnews.com/subscribe/"><b>Subscribe</b></a></li>
</ul></div>		</nav><!-- #site-navigation -->
		<div class="search-block">
			<div id="searchform" >
				<form action="https://www.breakingisraelnews.com" method="get">
					<button class="search-button" type="submit" value=""></button>
					<input type="text" id="s" name="s" value="" placeholder="Search..." style="width: 106px;">
				</form>
			</div>
		</div><!-- .search-block /-->
	</div>
		<div class="site-branding">
						<div class="site-title"><a href="https://www.breakingisraelnews.com/" rel="home">Breaking Israel News | Latest News. Biblical Perspective.</a></div>
		</div>

		<nav id="site-navigation" class="main-navigation" role="navigation">
			<span class="menu-toggle">Menu</span>
			<a href="#content" class="skip-link screen-reader-text" >Skip to content</a>
			<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-87034" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-87034"><a href="https://www.breakingisraelnews.com/category/jerusalem/">Jerusalem</a></li>
<li id="menu-item-65867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-65867"><a href="https://www.breakingisraelnews.com/category/christian-zionism/"><b>Christian Zionism</b></a></li>
<li id="menu-item-67846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-67846"><a href="https://www.breakingisraelnews.com/category/us-israel-relations/">US-Israel</a></li>
<li id="menu-item-354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-354"><a href="https://www.breakingisraelnews.com/category/idf/"><b>IDF</b></a></li>
<li id="menu-item-563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-563"><a href="https://www.breakingisraelnews.com/category/videos/"><b>News Videos</b></a></li>
<li id="menu-item-111520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-depth-0 menu-item-111520"><a href="https://www.breakingisraelnews.com/category/medical-miracles/">Medical &#038; Scientific Miracles</a></li>
<li id="menu-item-150095" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-150095"><a href="https://www.breakingisraelnews.com/tag/zaka/">Humanitarian Relief</a></li>
<li id="menu-item-146415" class="menu-item menu-item-type-custom menu-item-object-custom menu-depth-0 menu-item-146415"><a href="https://www.breakingisraelnews.com/tag/coronavirus/">Coronavirus</a></li>
<li id="menu-item-149403" class="menu-item menu-item-type-post_type menu-item-object-page menu-depth-0 menu-item-149403"><a href="https://www.breakingisraelnews.com/subscribe/"><b>Subscribe</b></a></li>
</ul></div>		</nav><!-- #site-navigation -->
	</header><!-- #masthead -->
	<!-- Functioning site branding for print: -->
	<div class="show_in_print" style="text-align: center; display: none; margin-top: 20px;"><img src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2013/06/BreakingIsraelNews1.jpg" width="500"></div>

<!-- /264857099/BIN/ROS/LB_1 -->
<div id='div-gpt-ad-LB_1' style="text-align:center" style='margin: 0 auto; width: 970px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-LB_1'); });
</script>
</div>

<!-- GPT AdSlot 1 for Ad unit 'BIN_LB_1' ### Size: [[970,300],[970,250],[970,90],[728,90],[320,100]] -->
<div class="gam-ad" id='div-gpt-ad-7234665-1' style="text-align:center" >
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-7234665-1'); });
  </script>
</div>
<!-- End AdSlot 1 -->


	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		<div class='code-block code-block-12' style='margin: 8px 0; clear: both;'>
<!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com -->
<div id="om-wqlfbwoq3uaqulixh9ao-holder"></div>
<script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="wqlfbwoq3uaqulixh9ao" data-user="56043" async></script>
<!-- / https://optinmonster.com --></div>

			
<article id="post-151245" class="post-151245 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-george-floyd tag-israel tag-united-states">
	<header class="entry-header">
		<h1 class="entry-title">Can We Keep the Focus on George Floyd’s Killer?</h1>

		<div class="entry-meta">
			By <span class="byline"><span class="author vcard"><a  href="https://www.breakingisraelnews.com/author/david-suissa/" class="url fn n">DAVID SUISSA</a></span></span>  <span class="posted-on"><a href="https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/" rel="bookmark"><time class="entry-date published updated" title="2020-06-02T06:05:48+03:00" datetime="2 Jun 2020"><span class="value">June 2, 2020 , 8:00 am</span></time></a></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->
	<!-- <div class="share-post">
		<div id="customWidget" class="pw-widget" pw:twitter-via="binalerts" style="float:left; margin-top:10px;" pw:url="">
			<a class="pw-button-facebook">
				<span class="pw-button-counter" style="float:right;margin-left:6px!important">
					<i class="pw-button-counter__brd"></i>
					<span class="pw-button-counter__count ra1-pw-button-counter-value pw-box-counter" data-channel="facebook"></span>
				</span>
			</a>
			<a class="pw-button-twitter">
				<span class="pw-button-counter" style="float:right;margin-left:6px!important">
					<i class="pw-button-counter__brd"></i>
					<span class="pw-button-counter__count ra1-pw-button-counter-value pw-box-counter" data-channel="twitter"></span>
				</span>
			</a>
		</div>

		<div class="pw-widget pw-size-large" style="float:right; margin-top:10px; margin-left:10px;" pw:url="">
			<a class="pw-button-print "></a>
		</div>
		<div class="pw-widget pw-counter-vertical" pw:twitter-via="binalerts" style="float:right;" pw:url="">
			<a class="pw-button-googleplus pw-look-native"></a>
			<a class="pw-button-email pw-look-native"></a>
			<a class="pw-button-post-share"></a>
		</div>
	</div>  .share-post -->



	<div class="entry-content" itemscope itemtype ="http://schema.org/NewsArticle">
				<div class="featured-image wp-caption aligncenter"><img width="660" height="330" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931.jpg" class="attachment-single-leader size-single-leader wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931.jpg 660w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931-300x150.jpg 300w" sizes="(max-width: 660px) 100vw, 660px" /><p class="wp-caption-text">Minneapolis, MN / USA &#8211; May 29 2020: Aftermath of Riots Fueled by the Death of George Floyd Under Police Custody. (Shutterstock)</p></div>
		<div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/" data-a2a-title="Can We Keep the Focus on George Floyd’s Killer?"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.breakingisraelnews.com%2F151245%2Fcan-we-keep-the-focus-on-george-floyds-killer-opinion%2F&amp;linkname=Can%20We%20Keep%20the%20Focus%20on%20George%20Floyd%E2%80%99s%20Killer%3F" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.breakingisraelnews.com%2F151245%2Fcan-we-keep-the-focus-on-george-floyds-killer-opinion%2F&amp;linkname=Can%20We%20Keep%20the%20Focus%20on%20George%20Floyd%E2%80%99s%20Killer%3F" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.breakingisraelnews.com%2F151245%2Fcan-we-keep-the-focus-on-george-floyds-killer-opinion%2F&amp;linkname=Can%20We%20Keep%20the%20Focus%20on%20George%20Floyd%E2%80%99s%20Killer%3F" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.breakingisraelnews.com%2F151245%2Fcan-we-keep-the-focus-on-george-floyds-killer-opinion%2F&amp;linkname=Can%20We%20Keep%20the%20Focus%20on%20George%20Floyd%E2%80%99s%20Killer%3F" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Fwww.breakingisraelnews.com%2F151245%2Fcan-we-keep-the-focus-on-george-floyds-killer-opinion%2F&amp;linkname=Can%20We%20Keep%20the%20Focus%20on%20George%20Floyd%E2%80%99s%20Killer%3F" title="Print" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd a2a_counter addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><p>The death of George Floyd at the hands of Minneapolis cop Derek Chauvin, who dug his knee into Floyd’s neck, feels all too familiar. Like Eric Garner in New York, Floyd cried out, “I can’t breathe.” As with Michael Brown’s death in Ferguson, riots ensued. Floyd’s death also occurred not far from where an unarmed Philando Castille was killed by police in 2016.</p><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- GPT AdSlot 1 for Ad unit 'BIN_ARTICLE_1' ### Size: [[300,250]] -->
<div class="gam-ad" id='div-gpt-ad-5237127-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-5237127-1'); });
  </script>
</div>
<!-- End AdSlot 1 --></div>

<p>In other words, we’ve seen this movie before.</p>
<p>Well, yes and no.</p>
<p>This latest episode of a heartless cop crushing his knee into a poor man’s neck, while his fellow cops just stood by, seemed to reach another level. The revulsion was instant and widespread, with condemnations from police chiefs across the country. No one was cautioning that we should “get all the facts” before “rushing to judgement.”</p><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- GPT AdSlot 2 for Ad unit 'BIN_ARTICLE_2' ### Size: [[300,250]] -->
<div class="gam-ad" id='div-gpt-ad-5237127-2'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-5237127-2'); });
  </script>
</div>
<!-- End AdSlot 2 --></div>

<p>The cruel face of an abusive cop oblivious to the cries of a dying man was all we needed to see, and it sent everyone into a tizzy.</p>
<p>It also felt like a tipping point, a final straw that turned frustration and anger into rage and fury. In the midst of the pandemic crisis, when so many have lost their lives and livelihoods, Floyd’s death was the match that lit a national tinderbox.</p>
<p>Equally outrageous was the failure to immediately arrest Chauvin. The killing occurred on a Monday; authorities didn’t arrest him until Friday, well after the riots had started. As legal expert and former prosecutor Andrew McCarthy wrote in <em>National Review Online</em>, “The claim that the prosecutor had to wait to authorize an arrest until the investigators nailed down all the evidence is nonsense.”</p><div class='code-block code-block-5' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- /21822990548/BIN_ARTICLE_3 -->
<center><div class="gam-ad" id='div-gpt-ad-1572360821086-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1572360821086-0'); });
  </script>
</div></center></div>

<p>He added: “This was not a fleeting incident, or a situation in which Floyd was resisting—he was pleading for his life. … Obviously, it was a crime. When a violent crime has clearly happened, the person who committed it should be placed under arrest, immediately.”</p>
<p>It’s quite possible that an immediate arrest of Chauvin and his three accomplices might have prevented or at least mitigated the rioting. In any case, the failure of law enforcement to move swiftly and forcefully was unforgivable.</p>
<a href="https://www.breakingisraelnews.com/sign-up-here/#fI26J4dDCSKsIZ6i.97" target="_blank" rel="attachment noopener wp-att-16257 noreferrer"><img class="size-full wp-image-91145 aligncenter" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2017/07/28-BIN-OpEd-Experts-300x2501.png" alt="" width="300" height="250" /></a>
<p>What especially pains me is that the rioting has taken over the story. Floyd’s murderer doesn’t deserve that we change the subject. <em>His crime </em>ought to remain the story. But that’s not how the media works. When the media sees burning police cars, the looting of small businesses or an attack on CNN offices, you can be sure they’ll be all over it.</p><div class='code-block code-block-13' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/21752231759/bin_multisize_inarticle_native', [[1, 1], 'fluid']).display();
</script></div>

<p>Even if it’s only a criminal minority that is exploiting the chaos, for the media, the optics of riots are like red meat to a lion. That is where we are now: “Violent Protests Break Out Across Nation” has become the major headline.</p>
<p>It goes without saying that there’s no excuse for violence, looting and destruction of property, just as there’s no excuse for an overly aggressive police response to the demonstrations. But the deeper tragedy, as I see it, is that the rioting is undermining and overtaking a worthy cause.</p>
<p>Instead of talking about police violence, we’re talking more about protester violence that makes for dramatic media images. That’s not justice.</p>
<p>During a press conference on Saturday, Los Angeles Mayor Eric Garcetti urged people who would resort to violence, “Do not do a disservice to the memory of George [Floyd.] … Do not make a disservice to the folks who have died at the hands of the brutality that we all stand against.”</p>
<p>These are easy comments to make for those who are not victims of racism and violence, but the mayor has a point. The rage among protesters is justified, but the rioting doesn’t advance their cause.</p>
<p>Instead of the Summer of Riots, this should be the summer of “I Can’t Breathe.”</p>
<p>If I had a magic wand, I would organize Million People Marches with protesters across the nation wearing masks that say, “I can’t breathe.” In fact, everyone who wears a mask during these pandemic times should write “I can’t breathe” on them.</p>
<p>An “I can’t breathe” solidarity movement that would rally the nation would keep the focus on the original crime and the original issue. Looking beyond the present riots, it’s not too late to plan national marches for July Fourth, our national holiday of freedom.</p>
<p>George Floyd, along with other victims of racism and police violence, deserves nothing less.</p>
<p><em><span style="color: #000000;">Reprinted with author&#8217;s permission from</span> <a href="https://www.jns.org/opinion/can-we-keep-the-focus-on-george-floyds-killer/" target="_blank" rel="noopener noreferrer">Jewish News Syndicate</a></em></p>
<div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script>
  (function(){
    var scr = document.createElement('script');
    scr.src = 'https://adklip.bbvms.com/p/bin/q/catSort:bin.js?iframeBreakout=true&sort=random_' + Math.round(Math.random()*40) + ' asc';
    document.currentScript.parentNode.insertBefore(scr, document.currentScript);
  })();
  </script>  </div>


		
		

<!-- /51987917/BIN_2017/BIN_BelowArticle -->
<!--<div id='div-gpt-ad-1487602151590-4' style="max-width: 300px; margin: 0px auto;">
<script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/264857099/BIN/ROS/HP_Interstitial', [1, 1]).setTargeting('BIN_pageType', 'article').display();
</script>
</div>


<!-- Recommended content -->

<!-- <div id="rcjsload_f535c7"></div>

<script type="text/javascript">

(function() {

var referer="";try{if(referer=document.referrer,"undefined"==typeof referer||""==referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);

var rcel = document.createElement("script");

rcel.id = 'rc_' + Math.floor(Math.random() * 1000);

rcel.type = 'text/javascript';

rcel.src = "https://trends.revcontent.com/serve.js.php?w=87653&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;

rcel.async = true;

var rcds = document.getElementById("rcjsload_f535c7"); rcds.appendChild(rcel);

})();

</script> -->
<!-- end Recommended content -->
  <!--  <interaction data-token="59abdcfd645666010023863d" data-context="true" data-tags="" data-fallback="true"></interaction> -->

    <!-- Whizzco Widget -->
<!-- <div class="ads_container_12374168" website_id="1237" widget_id="4168"></div>
<script type="text/javascript">var uniquekey = "12374168"; </script>
<script type="text/javascript" src="https://cdn.whizzco.com/scripts/widget/widget_t_v2.js"></script> -->
<!-- End Whizzco Widget -->

    <!-- RevContent -->
<!--<div id="rcjsload_e5fbeb"></div>
<script type="text/javascript">
(function() {
function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}
ad_block_test(function(is_blocked){
var widget_id = 79500;
if (is_blocked === true) {
widget_id = 86470;
}
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth) +"&referer="+referer + '&is_blocked=' + is_blocked;
rcel.async = true;
var rcds = document.getElementById("rcjsload_e5fbeb"); rcds.appendChild(rcel);
});
})();
</script>-->
<!-- end RevContent -->


	<!-- .entry-content -->

	<footer class="entry-footer">

		
		<!-- <div class="share-post">
			<div id="customWidget" class="pw-widget"  pw:twitter-via="binalerts" style="float:left; margin-top:10px;" pw:url="">
				<a class="pw-button-facebook">
					<span class="pw-button-counter" style="float:right;margin-left:6px!important">
						<i class="pw-button-counter__brd"></i>
						<span class="pw-button-counter__count ra1-pw-button-counter-value pw-box-counter" data-channel="facebook"></span>
					</span>
				</a>
				<a class="pw-button-twitter">
					<span class="pw-button-counter" style="float:right;margin-left:6px!important">
						<i class="pw-button-counter__brd"></i>
						<span class="pw-button-counter__count ra1-pw-button-counter-value pw-box-counter" data-channel="twitter"></span>
					</span>
				</a>
			</div>

			<div class="pw-widget pw-size-large" style="float:right; margin-top:10px; margin-left:10px;" pw:url="">
				<a class="pw-button-print "></a>
			</div>
			<div class="pw-widget pw-counter-vertical" pw:twitter-via="binalerts" style="float:right;" pw:url="">
				<a class="pw-button-googleplus pw-look-native"></a>
				<a class="pw-button-email pw-look-native"></a>
				<a class="pw-button-post-share"></a>
			</div>
		</div>  .share-post -->

<!-- Removed tags section so fb widget is higher		<div class="article-footer-tags">
			<div class="entry-tags">Tagged with: <a href="https://www.breakingisraelnews.com/tag/george-floyd/" rel="tag">George Floyd</a> <a href="https://www.breakingisraelnews.com/tag/israel/" rel="tag">Israel</a> <a href="https://www.breakingisraelnews.com/tag/united-states/" rel="tag">United States (US)</a></div>
		</div> -->
	</footer><!-- .entry-footer -->
</article><!-- #post-## -->



<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/" data-width="640" data-order-by="social"></div>
</div></div>

			
		<div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/21752231759/bin_multisize_native', [[1, 1], 'fluid']).display();
</script></div>

		</main><!-- #main -->
	</div><!-- #primary -->

			<div id="secondaryRight" class="widget-area mid-size" role="complementary">
			<div class="widget-area-inner">
			<aside id="ai_widget-6" class="widget ai_widget"><div class='code-block code-block-6' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- GPT AdSlot 8 for Ad unit 'BIN_SKY_1' ### Size: [[160,600],[300,600],[300,250],'fluid'] -->
<center><div class="gam-ad" id='div-gpt-ad-7234665-8'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-7234665-8'); });
  </script>
	</div></center>
<!-- End AdSlot 8 --></div>
</aside>
		 <aside id="category_posts_widget-4" class="widget widget_category_posts"><h2 class="widget-title"><span>Latest News		</span></h2>			<ul>
				<li><a class="article-thumb" href="https://www.breakingisraelnews.com/151229/secret-deal-results-in-saudi-arabia-challenging-turkey-for-control-of-temple-mount/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/03/templeMountEmpty-1-55x55.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/03/templeMountEmpty-1-55x55.jpg 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/03/templeMountEmpty-1-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151229/secret-deal-results-in-saudi-arabia-challenging-turkey-for-control-of-temple-mount/">Secret Deal Results in Saudi Arabia Challenging Turkey for Control of Temple Mount</a><time class="article-date">June 1, 2020 , 2:50 pm</time></div></li><li><a class="article-thumb" href="https://www.breakingisraelnews.com/151223/israel-loan-association-scrambles-to-help-rehabilitate-economy-where-government-failed/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2018/09/Food_Shuk-55x55.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2018/09/Food_Shuk-55x55.jpg 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2018/09/Food_Shuk-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151223/israel-loan-association-scrambles-to-help-rehabilitate-economy-where-government-failed/">Israel Loan Association Scrambles to Help Rehabilitate Economy where Government Failed</a><time class="article-date">June 1, 2020 , 2:27 pm</time></div></li><li><a class="article-thumb" href="https://www.breakingisraelnews.com/151220/more-muslim-states-break-away-from-mold-side-with-israel-on-annexation/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2017/06/bin-salman-55x55.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2017/06/bin-salman-55x55.jpg 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2017/06/bin-salman-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151220/more-muslim-states-break-away-from-mold-side-with-israel-on-annexation/">More Muslim States Break Away from Mold: Side with Israel on Annexation</a><time class="article-date">June 1, 2020 , 2:20 pm</time></div></li><li><a class="article-thumb" href="https://www.breakingisraelnews.com/151187/israel-reveals-new-corona-emergency-laws-and-theyre-terrifying/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/F200525FF85-1-55x55.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/F200525FF85-1-55x55.jpg 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/F200525FF85-1-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151187/israel-reveals-new-corona-emergency-laws-and-theyre-terrifying/">Israel Reveals New Corona-Emergency Laws and they&#8217;re Terrifying</a><time class="article-date">June 1, 2020 , 11:37 am</time></div></li><li><a class="article-thumb" href="https://www.breakingisraelnews.com/151180/iran-turkey-seemingly-support-violent-riots-us/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931-55x55.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931-55x55.jpg 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/shutterstock_1744882931-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151180/iran-turkey-seemingly-support-violent-riots-us/">Iran and Turkey Support Violent Riots in US</a><time class="article-date">June 1, 2020 , 10:20 am</time></div></li>			</ul>
	</aside>				<aside id="ai_widget-7" class="widget ai_widget"><div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- GPT AdSlot 2 for Ad unit 'BIN_MPU_1' ### Size: [[336,280],[300,250],'fluid'] -->
<center><div class="gam-ad" id='div-gpt-ad-7234665-2'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-7234665-2'); });
  </script>
	</div></center>
<!-- End AdSlot 2 -->
</div>
</aside><aside id="ai_widget-8" class="widget ai_widget"><div class='code-block code-block-8' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- GPT AdSlot 3 for Ad unit 'BIN_MPU_2' ### Size: [[336,280],[300,250],'fluid'] -->
<center><div class="gam-ad" id='div-gpt-ad-7234665-3'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-7234665-3'); });
  </script>
	</div></center>
<!-- End AdSlot 3 --></div>
</aside><aside id="author_post_widget-10" class="widget widget_author_posts"><h2 class="widget-title"><span>By DAVID SUISSA</span></h2>			<ul>
							<li><a href="https://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/" rel="bookmark" title="Can We Keep the Focus on George Floyd’s Killer?">Can We Keep the Focus on George Floyd’s Killer?</a></li>
							<li><a href="https://www.breakingisraelnews.com/150927/with-high-holidays-on-the-horizon-high-anxiety-for-synagogues-opinion/" rel="bookmark" title="With High Holidays on the Horizon, High Anxiety for Synagogues">With High Holidays on the Horizon, High Anxiety for Synagogues</a></li>
							<li><a href="https://www.breakingisraelnews.com/149679/if-you-hate-flying-now-just-wait-opinion/" rel="bookmark" title="If you Hate Flying Now, Just Wait">If you Hate Flying Now, Just Wait</a></li>
						</ul>
						<a href="https://www.breakingisraelnews.com/author/david-suissa/"> All (15)</a>
			
			</aside>
		 <aside id="category_posts_widget-3" class="widget widget_category_posts"><h2 class="widget-title"><span>Viral Israel Videos		</span></h2>			<ul>
				<li><a class="article-thumb" href="https://www.breakingisraelnews.com/151215/bricks-randomly-showing-up-at-protests-across-the-us/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/bricks-55x55.png" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/bricks-55x55.png 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/06/bricks-150x150.png 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151215/bricks-randomly-showing-up-at-protests-across-the-us/">Bricks Randomly showing up at Protests across the US</a></div></li><li><a class="article-thumb" href="https://www.breakingisraelnews.com/151089/israels-lebanese-soldiers/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/05/slalebanon-55x55.png" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/05/slalebanon-55x55.png 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/05/slalebanon-150x150.png 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151089/israels-lebanese-soldiers/">Israel&#8217;s Lebanese Soldiers</a></div></li><li><a class="article-thumb" href="https://www.breakingisraelnews.com/151028/idf-multiple-terrorist-attacks-thwarted/"><img width="55" height="55" src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/05/Capture-5-55x55.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/05/Capture-5-55x55.jpg 55w, https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2020/05/Capture-5-150x150.jpg 150w" sizes="(max-width: 55px) 100vw, 55px" /></a><div><a class="article-title" href="https://www.breakingisraelnews.com/151028/idf-multiple-terrorist-attacks-thwarted/">IDF: Multiple Terrorist Attacks Thwarted</a></div></li>			</ul>
	</aside>				<aside id="ai_widget-9" class="widget ai_widget"><div class='code-block code-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- GPT AdSlot 9 for Ad unit 'BIN_SKY_2' ### Size: [[160,600],[300,600],[300,250],'fluid'] -->
<center><div class="gam-ad" id='div-gpt-ad-7234665-9'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-7234665-9'); });
  </script>
	</div></center>
<!-- End AdSlot 9 --></div>
</aside>			</div>
		</div><!-- #secondary -->
	
    <div class="holder">
            </div><!-- .ads -->

	</div><!-- #content -->

	<footer id="footer" class="site-footer" role="contentinfo">
		<div class="inner-footer">
			<div class="site-footer-left" role="contentinfo">
				<div class="widget-area-inner">
											<aside id="text-7" class="widget widget_text"><h2 class="widget-title"><span>About BIN</span></h2>			<div class="textwidget"><p><a href="https://breakingisraelnews.com">Breaking Israel News</a> offers a fresh and Biblical perspective on the latest news from Israel and the Middle East. Our bias is not liberal nor conservative &#8211; just Biblical.</p>
<p><a href="https://breakingisraelnews.com/about-us">Our Staff</a></p>
</div>
		</aside><aside id="text-8" class="widget widget_text"><h2 class="widget-title"><span>Contact BIN</span></h2>			<div class="textwidget"><p>We would love to hear from you.</p>
<p><a href="https://breakingisraelnews.com/contact-us">Contact Us</a></p>
</div>
		</aside>									</div>
			</div>
			<div class="site-footer-right" role="contentinfo">
				<div class="widget-area-inner">
											<aside id="text-9" class="widget widget_text"><h2 class="widget-title"><span>Advertise with BIN</span></h2>			<div class="textwidget"><p>Reach our growing audience of staunch Jewish and Christian supporters of Israel. <a href="https://israelmedianetwork.com/#contact_us ">Contact our Israel365MEDIA agency here</a> or send an email to <a href="mailto:info@israelmedianetwork.com">info@israelmedianetwork.com</a>.<br />
Many of our emails are created in <a target="_blank" href="https://stripo.email?utm_source=website&amp;utm_medium=footer&amp;utm_campaign=breakingisraelnews" rel="noopener noreferrer">stripo.email</a></p>
</div>
		</aside><aside id="text-10" class="widget widget_text"><h2 class="widget-title"><span>Contribute to BIN</span></h2>			<div class="textwidget"><p>If you are passionate about Israel and interested in featuring your thoughts on our site, <a href="https://breakingisraelnews.com/blog-for-us">contact us</a> for more information.</p>
<p><a href="https://breakingisraelnews.com/our-contributors">Our Contributors</a></p>
</div>
		</aside>									</div>
			</div>
		</div>
		<div class="footer-bottom">
			<div class="container">
				<div class="alignright">
					 <a href="//www.breakingisraelnews.com/sitemap">Sitemap</a> | <a href="//www.breakingisraelnews.com/privacy-policy">Privacy Policy</a> | <a href="//www.breakingisraelnews.com/copyright-policy/">Copyright Policy</a>			</div>
						<div class="social-icons icon_16">
			<a  href="//www.breakingisraelnews.com/feed/" class="ttip" target="_blank" original-title="Rss"><img src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/themes/sahifa/images/socialicons/rss.png" alt="RSS"></a>	</div>


				<div class="alignleft">
					© Copyright 2013 - 2020, All Rights Reserved			</div>
			</div><!-- .Container -->
		</div>

	</footer><!-- #colophon -->
	<div class="foot-wrapper">
	<div class="standard-foot">
			<div class="space1">&nbsp;</div><div class="logoholder"><a href="https://www.israel365.com"><img src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2016/09/Israel365-logo-dark-2.png" alt="israel365 logo" /></a></div><div class="space2">&nbsp;</div><div class="logoholder"><a href="http://www.theisraelbible.com"><img src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2016/09/tib-footer-bin.jpg" alt="theisraelbiblelogo" /></a></div><div class="space2">&nbsp;</div><div class="logoholder"><a href="http://www.israelmedianetwork.com"><img src="https://mk0breakingisralps2c.kinstacdn.com/wp-content/uploads/2016/09/IMN-Logo-TextSide-2.png" alt="israel media network logo" /></a></div><div class="space1">&nbsp;</div>
			</div>
			</div>
</div><!-- #page -->
	<!--<script>
		window.sharePromtConfig = {
		widgetPublisherKey: '3441d986llp5sbidnrvc',
		type: 'toolbar',
		position: 'bottom-left',
		effect: 'slide',
		offset_show: -2000,
		show: 'scroll.end',
		post_widget: {
			buttons: [{id:'facebook', look:'native'}, {id:'twitter', look:'native'}, {id:'mail', look:'native'}, {id:'post-share', look:'native'}],
			size: 'xlarge'
		},
		template: '<a class="r1sp__close" data-action="close"></a><div class="r1sp__share-inl">Share with friends:</div> <div class="r1sp__widget-inlineb">{{widget}}</div>'
		};
	</script> -->
<?php// } ?>

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-K4Q3Z8"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: DI Floating Bar 5-20-20 --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="or5jj4owb8psqmek9abk" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > Stop Antisemitism > FloatingBar - Mobile --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="njw8wilftpspjwttcfnb" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > MP Lead Campaign > Mobile Bar --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="lgwl5ap4no11aeffqwe1" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > MP Lead Generation > Floating Bar --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="n816vxtx2pkwykhzafrh" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > Stop Antisemitim > Floating Bar Desktop --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="pszp0zdmkjwgc0pnxdgo" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: DI bar mobile V1 --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="zw1xn1fadaubjto8v8s9" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: bin floating bar 3-18-20 - C.V. --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="wo4bqisqsp5gy1lnng20" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: bin bar mobile --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="som8zzs8vgo39qd4emjm" data-user="56043" async></script><!-- / OptinMonster -->		<script type="text/javascript">var or5jj4owb8psqmek9abk_shortcode = true;var njw8wilftpspjwttcfnb_shortcode = true;var lgwl5ap4no11aeffqwe1_shortcode = true;var n816vxtx2pkwykhzafrh_shortcode = true;var pszp0zdmkjwgc0pnxdgo_shortcode = true;var zw1xn1fadaubjto8v8s9_shortcode = true;var wo4bqisqsp5gy1lnng20_shortcode = true;var som8zzs8vgo39qd4emjm_shortcode = true;</script>
		<script type='text/javascript'>
/* <![CDATA[ */
var php_data = {"ac_settings":{"tracking_actid":475857827,"site_tracking_default":1,"site_tracking":1},"user_email":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-content/plugins/activecampaign-subscription-forms/site_tracking.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="https:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='https://www.breakingisraelnews.com?v=3accdd'></script>
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-content/themes/bin-v2/dist/js/scripts.libs.3accdd.js'></script>
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-content/themes/bin-v2/dist/js/scripts.3accdd.js'></script>
<script type='text/javascript' src='https://mk0breakingisralps2c.kinstacdn.com/wp-content/plugins/optinmonster/assets/js/helper.js'></script>
<div id="fb-root"></div>		<script type="text/javascript">var omapi_localized = { ajax: 'https://www.breakingisraelnews.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '1556ab4f35', slugs: {"or5jj4owb8psqmek9abk":{"slug":"or5jj4owb8psqmek9abk","mailpoet":false},"njw8wilftpspjwttcfnb":{"slug":"njw8wilftpspjwttcfnb","mailpoet":false},"lgwl5ap4no11aeffqwe1":{"slug":"lgwl5ap4no11aeffqwe1","mailpoet":false},"n816vxtx2pkwykhzafrh":{"slug":"n816vxtx2pkwykhzafrh","mailpoet":false},"pszp0zdmkjwgc0pnxdgo":{"slug":"pszp0zdmkjwgc0pnxdgo","mailpoet":false},"zw1xn1fadaubjto8v8s9":{"slug":"zw1xn1fadaubjto8v8s9","mailpoet":false},"wo4bqisqsp5gy1lnng20":{"slug":"wo4bqisqsp5gy1lnng20","mailpoet":false},"som8zzs8vgo39qd4emjm":{"slug":"som8zzs8vgo39qd4emjm","mailpoet":false}} };</script>
				<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":151245,"object_key":"post","object_type":"post","term_ids":[1,6029,47,229]};</script>
		<script type="text/javascript">

jQuery(function() {
    jQuery("a:not([href*=breakingisraelnews\\.]):not([href^=#]):not([href^='']):not([href*=googleservices]):not([href*=pagead]), a[href*=feeds\\.breakingisraelnews], a[href$=\\/feed\\/], a[href^=mail]").on('click',function(e){
        var url = jQuery(this).attr("href");
        if (url && e.currentTarget.host != window.location.host) {
            _gaq.push(['_trackEvent', "Outbound Link", e.currentTarget.host, url, 0, 0])
            if (jQuery(this).attr("target") != '_blank' && jQuery(this).attr("href") != '' && !(e.metaKey || e.ctrlKey)){
                e.preventDefault();
                setTimeout('document.location = "' + url + '"', 100);
            }
        }
    });
});

jQuery('.ubm_premium_banner').click(function() {
	__ga('send', 'event', 'Ads', 'Click', 'CustomAds');
	__gaTracker('send', 'event', 'Ads', 'Clicks', 'CustomAds');
});
</script>
<script>
var pwidget_config = {
    trackAddressBar: true,
    defaults: {
    	url: "http://www.breakingisraelnews.com/151245/can-we-keep-the-focus-on-george-floyds-killer-opinion/"
    }
};
</script>

<script>
// MY CUSTOM SCRIPTS
jQuery('#heyoyaDiv').before('<em>Breaking Israel News offers news from Israel from an Orthodox Jewish perspective to both Jewish and Christian readers. We encourage open dialogue and welcome respectful questions. However, since we are an Orthodox Jewish site, our content is meant to stay focused on our shared heritage of the Hebrew Bible, and not Christian Scripture. We ask that our readers follow these guidelines when commenting on our site: <ul><li>&bull; Comments must be respectful and non-offensive.</li><li>&bull; Comments must not proselytize in any way.</li><li>&bull; Comments should stay focused on the Hebrew Bible and not refer to Christian Scripture.</li></ul>Any comments that do not comply with these guidelines may be removed from the site. Repeated violations of the guidelines could result in users being banned from commenting.</em>');
</script>




<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>


<!-- Google Tag Manager (noscript) --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: DI Floating Bar 5-20-20 --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="or5jj4owb8psqmek9abk" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > Stop Antisemitism > FloatingBar - Mobile --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="njw8wilftpspjwttcfnb" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > MP Lead Campaign > Mobile Bar --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="lgwl5ap4no11aeffqwe1" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > MP Lead Generation > Floating Bar --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="n816vxtx2pkwykhzafrh" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Client > Stop Antisemitim > Floating Bar Desktop --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="pszp0zdmkjwgc0pnxdgo" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: DI bar mobile V1 --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="zw1xn1fadaubjto8v8s9" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: bin floating bar 3-18-20 - C.V. --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="wo4bqisqsp5gy1lnng20" data-user="56043" async></script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: bin bar mobile --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="som8zzs8vgo39qd4emjm" data-user="56043" async></script><!-- / OptinMonster -->		<script type="text/javascript">var or5jj4owb8psqmek9abk_shortcode = true;var njw8wilftpspjwttcfnb_shortcode = true;var lgwl5ap4no11aeffqwe1_shortcode = true;var n816vxtx2pkwykhzafrh_shortcode = true;var pszp0zdmkjwgc0pnxdgo_shortcode = true;var zw1xn1fadaubjto8v8s9_shortcode = true;var wo4bqisqsp5gy1lnng20_shortcode = true;var som8zzs8vgo39qd4emjm_shortcode = true;</script>
		<div id="fb-root"></div><!-- /264857099/BIN/ROS/FI_tag -->
<div id='div-gpt-ad-FI_tag'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-FI_tag'); });
</script>

  

</div>
</body>
</html>
